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TopicsTopicsTopicsTopics

• Introduction to Step Debugging

• Debugging Demo

� CF8 Debugger

• Debugger Features
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• Debugger Features

• Why Use Debugging over CFDUMP, etc.

• Tips and Traps

• Learning More, FAQs, etc.
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About Charlie ArehartAbout Charlie ArehartAbout Charlie ArehartAbout Charlie Arehart

• Independent consultant since April 2006

• 11 yrs CF experience (26 in Enterprise IT)

� Member, Adobe Community Experts

� Certified Adv CF Developer (4 - 7), Cert. Adobe Instructor

� Writer in FAQU, Adobe DevCenter, CommunityMX, CFDJ, more

� Contributor to all three Ben Forta CF8 books

� Frequent speaker to user groups, conferences worldwide including CFUnited, 
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� Frequent speaker to user groups, conferences worldwide including CFUnited, 

cf.Objective, webDU, webManiacs, Scotch on the Rocks et al

� Run the Online ColdFusion Meetup (coldfusionmeetup.com)

� Living in Alpharetta, Georgia (north of Atlanta)

• Web home at www.carehart.org

� 200+ blog entries, 60+ articles, 70+ presentations, more

� UGTV: Recorded presentations by over 100 CFUG speakers

� Tools/Resources to Consider: 700+ tools/resources in 100+ categories 

� Consulting: available for troubleshooting, tuning, training

• For as few as days, hours, or even minutes; remote or on-site
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Solution CF 8Solution CF 8Solution CF 8Solution CF 8

• The session discusses the CF 8 Debugger, from Adobe

� Free with CF8

• Adobe ColdFusion 8 Extensions for Eclipse

� http://www.adobe.com/support/coldfusion/downloads.html#cfdevtools

� Works only on CF8
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� Works only on CF8

• Those on CF 6 or 7 should consider:

� FusionDebug, from Intergral 

� Commercial product (www.fusiondebug.com)

� Works on 6, 7, and 8

• Both are very similar, and yet different

� This talk focuses only on the CF8 debugger
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Introduction to Step DebuggingIntroduction to Step DebuggingIntroduction to Step DebuggingIntroduction to Step Debugging

• Understanding interactive debugging

� What can it do for you?

• Step through code line-by-line (where needed)

• View variables, in all scopes, at that point

• Watch particular expressions, to observe changes
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• Watch particular expressions, to observe changes

• Even change variables on the fly during execution

• And more

• Both based on Eclipse

� But don’t let that scare you!

� Even if using DW, HS, use Eclipse just for debugging
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Debugger DemoDebugger DemoDebugger DemoDebugger Demo

• Let’s see it in action
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Demoed FeaturesDemoed FeaturesDemoed FeaturesDemoed Features

• Set breakpoints, stepped through code

� Viewed variables, watched expressions

• Showed simple CFML code (CF Example Apps)

� Showed query data in variables pane

• Showed CFC-based code (Model Glue, Mach II)

� Showed scopes available in CFC methods (var and this scopes)
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� Showed scopes available in CFC methods (var and this scopes)

� Showed how stack is interactive 

• click to jump to lines in chain above current instruction

• Showed debugging Flex, Ajax apps

� Could also debug web svcs, Application.cfc, gateways, scheduled tasks

• Showed debugging inside CFSCRIPT

� Can also debug within CFOUTPUT, CFMAIL, CFSAVECONTENT, etc.
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About Underlying Eclipse About Underlying Eclipse About Underlying Eclipse About Underlying Eclipse 

• What is Eclipse?

� Free Java-based editor, greatly extensible

� Also the basis of Flex Builder, CFEclipse

• can add debugger to those, or have separate Eclipse 

installation
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installation

• Why did Adobe build this atop Eclipse?

� Built-in debugging features, just connected to CF

• Easy to install Eclipse plug-in (3.1, 3.2, 3.3)

� CF8 docs, articles explain how to install the plug-in

� I also have written a 20+ page chapter with details

• URLS for these offered at the end of the talk
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Server InstallationServer InstallationServer InstallationServer Installation

• Debugger requires minor modification of the CF 

server to be debugged

� CF8 Admin has Debugger Settings>“allow line 

debugging” checkbox 
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• In order to use the CF8 debugger, you must have 

enabled RDS during installation of CF

� If you did not, you need to enable it

• See http://www.adobe.com/go/tn_17276
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CF8 Debugger Relies on RDSCF8 Debugger Relies on RDSCF8 Debugger Relies on RDSCF8 Debugger Relies on RDS

• You then need to know the RDS password defined for your 

server (in the CF Admin)

� Or take advantage of the new multiple RDS user 

feature in the Security section of the ADMIN

• You will use this RDS password (or username/password) in 
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• You will use this RDS password (or username/password) in 

the CF8 Eclipse debugger setup steps

� Window>Preferences>ColdFusion>RDS configuration

� Documentation shared later offers more details

• Can test RDS and debugger setup

� Window>Preferences>ColdFusion>RDS 

configuration>Test Debugger/Connection
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Benefits Over CFDUMP/CFOUTPUTBenefits Over CFDUMP/CFOUTPUTBenefits Over CFDUMP/CFOUTPUTBenefits Over CFDUMP/CFOUTPUT

• Can debug when a CFOUTPUT/CFDUMP may not be possible 

� What are some examples?

• CFCOMPONENT/CFFUNCTION OUTPUT=false

• CFSILENT

• When generating non-HTML output

� Flex/Flash, Flash Remoting, Ajax, web services clients, etc
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� Flex/Flash, Flash Remoting, Ajax, web services clients, etc

• Debugging Application.cfc, event gateways, scheduled tasks

• Ever forget to remove debugging output?

• And a dozen other reasons

� See more details on all these at:

• http://carehart.org/blog/client/index.cfm/2006/9/7/fusiondebug_part2

_why_use_versus_cfdump
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Other FeaturesOther FeaturesOther FeaturesOther Features

• CF Admin setting for “timeout requests in x 

seconds” will affect debugging

� Timeout will generate timeout popup error in 

CF8 debugger
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� Either disable or increase the value in Admin

• Or use CFSETTING RequestTimeout=“xx” on 

pages being debugged

• Viewing generated HTML output

� CF8 debugger offers window to view that

• Window>Show View>Other>Debug Output Buffer
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Other Features (cont.)Other Features (cont.)Other Features (cont.)Other Features (cont.)

• Breaking on run-time exceptions

� CF8 debugger can be configured to break on 

exceptions

• window>preferences>coldfusion>debug settings

• Will stop on most (not all) error (pops up window in debugger, 
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• Will stop on most (not all) error (pops up window in debugger, 

error shown to user when done debugging)

• Even stops and shows pages you were not debugging

• Note that it also stops on code that throws errors

� Could be a negative in some code 

• Note there’s a fix related to this in the new CF8 Cumulative 

Hot Fix

� http://www.adobe.com/go/kb402466
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Other Features (cont.)Other Features (cont.)Other Features (cont.)Other Features (cont.)

• Ability to control variables shown

� selectable via window>preferences>coldfusion>debug 

settings>Debugger Scopes

• Ability to set variables on the fly

� In either the Variables or Expressions panes, right-click and 

choose “Change Value”
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choose “Change Value”

• Ability to set watch expressions from code

� via Expressions window

• You can debug remote or central server (test, production)

� Only first requesting user of a page will be debugged

� Multiple developers can debug on one server (could do in test)

• RDS security controls who is allowed to access debugger
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Other Features (cont.)Other Features (cont.)Other Features (cont.)Other Features (cont.)

• If file edited outside of Eclipse, breakpoints won’t move 

(affects both)

� May end up on line that keeps breakpoint from firing

• Can disable debugging temporarily

� “Disable checkpoints” option in Eclipse
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� “Disable checkpoints” option in Eclipse

� “stop debugging” button in CF8 Admin (for CF8 

debugger)
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TipsTipsTipsTips

• No need to create mappings if Eclipse and CF on same 

machine

� Run>Debug>ColdFusion Application>yourconfig

� Otherwise, use “add mapping” there indicating both 

Eclipse and CF path
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Eclipse and CF path

• Favor Step-over to Step-Into

� Will step into tags like CFDUMP, CFSAVECONTENT, 

etc, which actually are CFM files

• cfusion\wwwroot\WEB-INF\cftags

� Gets error in CF8 debugger
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Tips (cont.)Tips (cont.)Tips (cont.)Tips (cont.)

• In multiserver edition

� Must edit jvm.config by hand

• Jvm.config for multiserver in C:\JRun4\bin

• See docs for details
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� Also, consider creating unique config for cf 

instance (rather than at jrun4 level), otherwise 

CF may not start in some situations
• http://mkruger.cfwebtools.com/index.cfm/2006/4/17/multiserver

• http://www.doughughes.net/index.cfm?event=viewEntry&entryId=244
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TricksTricksTricksTricks

• Available shortcuts in Eclipse

� Breakpoint: ctrl-shift-b

� Step into/over/return/resume: f5/f6/f7/f8

• Commands also available on “run” menu

� Double-click on stack trace line/breakpoints list

• Opens file at that line
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• Opens file at that line

• If Debugger installed but not visible

� use Window>Open Perspective>Other>Debug

• If Navigator pane not visible

� use Window>Show View>Other>General>Navigator

• If Expressions tab not visible

� use Window>Show View>Other>Debug>Expressions
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Tricks (cont)Tricks (cont)Tricks (cont)Tricks (cont)

• Find command in Variables, Expressions panes

� Ctrl-f, or right-click+find

� Available wildcards: ? And *

• Can copy variable/vals to clipboard with “Copy 
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• Can copy variable/vals to clipboard with “Copy 

variables”

• Can “group” breakpoints, by file/project, or 

“working sets”

• Can export/import breakpoints
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Learning MoreLearning MoreLearning MoreLearning More

• Documentation: CF8 ColdFusion Developer’s Guide

� http://livedocs.adobe.com/coldfusion/8/htmldocs/using

debugger_1.html

• About the ColdFusion Debugger

• Installing and uninstalling the ColdFusion Debugger
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• Installing and uninstalling the ColdFusion Debugger

• Setting up ColdFusion to use the Debugger

• About the Debug perspective

• Using the ColdFusion Debugger

• Viewing ColdFusion log files

� http://livedocs.adobe.com/coldfusion/8/htmldocs/help.h

tml?content=basiconfig_19.html
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Learning More (cont.)Learning More (cont.)Learning More (cont.)Learning More (cont.)

• Other resources

� My chapter in ColdFusion 8 Web Application 

Construction Kit Volume 2: Application Development

• "Using the CF8 Debugger“ (25 pages)

• Available online
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• Available online

� http://www.forta.com/books/0321515463/CFWACK8-2-

EChapters.pdf

� My FusionAuthority Quarterly Update article in CF8 

Special Edition

• “The ColdFusion 8 Debugger Explained: Interactive Step 

Debugging for ColdFusion 8”
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Learning More (cont.)Learning More (cont.)Learning More (cont.)Learning More (cont.)

• Other resources (cont.)

� “Using the ColdFusion 8 step-through debugger for 

Eclipse”, Brian Szoszorek
• http://www.adobe.com/devnet/coldfusion/articles/debugger.html

� “Getting Started With The ColdFusion Debugger”, Ben 
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� “Getting Started With The ColdFusion Debugger”, Ben 

Forta

• http://www.forta.com/blog/index.cfm/2007/5/30/CF8-

Debugger-Getting-Started

� ColdFusion 8 Debugger Resources and Tips

• http://www.thecrumb.com/2007/08/31/coldfusion-8-debugger-

resources-and-tips/
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FAQsFAQsFAQsFAQs

• Does it work with CF4, 5, 6, or 7?

� No, works only with CF 8

� FusionDebug runs on 6, 7, or 8

• Does it run on Linux? OS X? other platform

� Yes, runs on any platform that runs Eclipse 

• and can debug any server that runs ColdFusion
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• and can debug any server that runs ColdFusion

• How much does it cost?

� It’s free

• Is it included in CF 8 Standard, Enterprise, and Developer editions?

� Yes

• How do I get support?

� CF Support forums (General)

• http://www.adobe.com/cfusion/webforums/forum/index.cfm?forumid=1
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FAQs (cont.)FAQs (cont.)FAQs (cont.)FAQs (cont.)

• Does it support debugging Javascript? 

Actionscript? Java?

� No, that’s left to other debuggers

� Eclipse already can debug Java, and 
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� Eclipse already can debug Java, and 

FlexBuilder can debug ActionScript

� Other tools offer Javascript debugging inside 

Eclipse

• JavaScript Eclipse Debugger Plug-ins:

� http://www.aptana.com/

� http://www.myeclipseide.com/index.php?module=htmlpag

es&func=display&pid=270#jsdebug

24



ConclusionConclusionConclusionConclusion

• Great solution, finally, for CFML debugging

• It can be challenging to get started

� Please refer to the resources I’ve written

• Yes, it’s based on Eclipse

� But again, you can continue to use your favorite editor, 
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� But again, you can continue to use your favorite editor, 

and just use Eclipse for debugging

• Getting used to relying on debugger

� The challenge is simply remembering to use it!

� Try for yourself and see if it doesn’t help
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Questions on presentationQuestions on presentationQuestions on presentationQuestions on presentation

• Charlie Arehart

� charlie@carehart.org

• I’d really appreciate your feedback

� http://carehart.org/feedback/

• Also available for setup and implementation consulting
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• Also available for setup and implementation consulting

� Also other developer productivity coaching, system 

admin and tuning support, and more

� Remote or on-site

� Again, for as little as days, hours, even minutes

� http://carehart.org/consulting/

• Finally, evaluationsW
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EvaluationsEvaluationsEvaluationsEvaluations

• Title: DDT228 - Interactive Step Debugging 

with the CF8 Debugger

• Speaker: Charlie Arehart
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